Debian安装PHP5.6

Debian apt-get默认安装是php5.4,为了运行laravel升下级。

wget http://www.dotdeb.org/dotdeb.gpg
apt-key add dotdeb.gpg
apt-get update

以上是更新。

下面更新下PHP。

apt-get install php5

安装完成后我们查看下PHP版本。

php -v

最后重启下Apache。

service apache2 restart


在安装中出现以下错误。

php5-cli : Depends: php5-common (= 5.4.45-0) but 5.6.29-1~+7.1 is to be installed
 php5-readline : Depends: php5-cli (= 5.6.29-1+7.1) but 5.4.45-0+deb7u6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

这里运行下,即可。

apt-get -f install